Molcas Forum

Support and discussions for Molcas and OpenMolcas users and developers

You are not logged in.

Announcement

Welcome to the Molcas forum. You can choose an avatar and change the default style by going to "Profile" → "Personality" or "Display".

#1 2019-11-27 17:33:33

Sarah
Member
Registered: 2016-08-01
Posts: 38

[SOLVED] LUSCUS-X Window System error

Dear Molcas/Luscus Team,

I used to run "Luscus" on my work station but after updating my Linux (now: Linux 4.4.0-165-generic x86_64) I am getting the following error:

The program 'luscus' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 284 error_code 2 request_code 154 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Would you please help me solve this issue.
Thank you and best wishes,
Sarah

Offline

#2 2019-12-19 13:29:05

valera
Administrator
Registered: 2015-11-03
Posts: 102

Re: [SOLVED] LUSCUS-X Window System error

Dear Sarah,
did you recompiled luscus? it looks like a bug caused by a changed behaviour of some system library. if recompilation doesn't help, you have to run luscus with debugger (in your post there is an instruction smile). without your graphical libraries I can't reproduce the error..


The main reason of my preference with respect to operating systems: cp is two characters, but copy is four.

Offline

#3 2019-12-19 14:39:09

Sarah
Member
Registered: 2016-08-01
Posts: 38

Re: [SOLVED] LUSCUS-X Window System error

Thanks a lot Valera!

The problem was solved after I updated my Linux.

Happy Holidays to Molcas/Luscus team and thank you all for your support in 2019.
Sarah

Offline

Board footer

Powered by FluxBB

Last refresh: Today 12:19:23