Molcas Forum

Support and discussions for Molcas and OpenMolcas users and developers

You are not logged in.

Announcement

Welcome to the Molcas forum. You can choose an avatar and change the default style by going to "Profile" → "Personality" or "Display".

#1 2019-04-18 10:18:11

rafapa
Member
Registered: 2019-04-18
Posts: 2

Molcas 8.4 beta and MKL installation problem.

Hi,
I run setup choosing gfortran, MKL & serial.
Running make triggers the following error:
/usr/bin//gfortran -o ../../bin/check.exe  main.o -Wl,--start-group -L../../lib -lcheck -L../../lib -laniso_util -lblas_m_util -ldga_util -lfim_util -lga2_util -lgrid_it_util -lhyper_util -lio2_util -llapack_m2_util -llapack_m_util -llibmsym_util -lmknemo_util -lmsym_util -lalaska_util -lamfi_util -lcasvb_util -lccsd_util -lccsort_util -lcct3_util -lcholesky_util -ldft_util -ldkh_old_util -ldkh_util -lembedding_util -lespf_util -lfaiemp_util -lfmm_util -lfock_util -lga_util -lgateway_util -lgrid_util -lguessorb_util -linput_util -lintegral_util -lio_util -llinalg_util -llocalisation_util -lloprop_util -llucia_util -lmisc_util -lmma_util -lmolcas_ci_util -lnq_util -loneint_util -lpcm_util -lpeekpoke_util -lppint_util -lproperty_util -lquadpack_util -lquater_util -lrestart_util -lri_util -lrunfile_util -lrys_util -lslapaf_util -lsort_util -lsystem_util -ltransform_util -lxml_util -lModules  -Wl,--end-group "LIB"

It seems to me there is something wrong with the XLIB variable. The Makefile defines
XLIB   = "$XLIB"
but I have no such variable defined anywhere else.

If I remove the ${XLIB} from the following line in the Makefile it seems to work.
        ${FCOMPILER} -o ${@} ${LDFLAGS} main.o ${LIBGROUP} ${XLIB} ${EXTRA_OPTS}

I need to do it in all the Makefiles.
Could somebody tell me what I am doing wrong?
Thanks,
Rafael

Offline

#2 2019-04-18 13:02:17

Ignacio
Administrator
From: Uppsala
Registered: 2015-11-03
Posts: 506

Re: Molcas 8.4 beta and MKL installation problem.

I would guess there is an error in setup, line 1078, it should probably say "XLIB=\"$XLIB\""

Offline

#3 2019-04-18 17:44:55

rafapa
Member
Registered: 2019-04-18
Posts: 2

Re: Molcas 8.4 beta and MKL installation problem.

Same problem.
I suggest two changes:
1. Create the install.sh so it uses the shell. I was using the tcsh and executing from the command line reports that the XLIB command does not exist.
Something like
echo "#!/bin/sh" >install.sh
echo "# feel free to edit!" >>install.sh
echo "XLIB=$XLIB" >>install.sh

should work.

2. Line 1089 should read
export XLIB=$XLIB
instead of
export XLIB=\"\$XLIB\"

Thanks for the help,
Rafael

Last edited by rafapa (2019-04-18 18:36:46)

Offline

#4 2019-05-08 09:22:43

valera
Administrator
Registered: 2015-11-03
Posts: 94

Re: Molcas 8.4 beta and MKL installation problem.

Thanks, Rafael!
yes, the bug was already spotted and fixed.


The main reason of my preference with respect to operating systems: cp is two characters, but copy is four.

Offline

Board footer

Powered by FluxBB

Last refresh: Today 00:08:23